Vim学习笔记-安装和终极配置

macOS系统默认自带的vim版本是7.3的,想要完全使用spf13-vim的配置,需要更新至7.4以上版本。最简单的办法是保留系统原有vim,用brew安装新版。

1
brew install vim

如果没安装brew,安装一下:

1
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

如果安装vim碰到错误“The requested URL returned error: 404 Not Found”,说明需要更新brew

1
brew update

如果更新brew碰到错误,尝试修复,然后再尝试更新和下载

1
cd $(brew --prefix) && git fetch && git reset --hard origin/master

然后安装spf13-vim终极配置:

1
curl https://j.mp/spf13-vim3 -L > spf13-vim.sh && sh spf13-vim.sh

OVER~